Learn how to resolve common SSO error
Error Message:
Unauthorized access. You do not have an application role associated with your account. Please contact your plan's user administrator.
Cause:
The account is configured to login through SSO, and the user's role is determined by Active Directory, but the configuration file is not in place so it is attempting to login through AVAIL's standard login flow in which the user does not have a role assigned.
Solution:
- Ensure that the ADFS.config file is in place on the user's machine at C:\Program Files\AVAIL.
- The ADFS.config file is the same for all users on the account, so it can be copied and pasted there from another user's machine.
Recommendation: Inform your AVAIL Administrator and/or IT that the ADFS.config file may not have been properly deployed to your machine.
Detailed information on SSO Integration can be found in our integration guides found in the Manage Your Account section of the Help Center.